Skip to content
Permalink
Browse files
Bump cryptography to 38 (#79067)
  • Loading branch information
balloob committed Sep 25, 2022
1 parent 0cc03c3 commit f41b69e19e4c13cc8a865f380a2ca020d9dc2750
Show file tree
Hide file tree
Showing 7 changed files with 7 additions and 13 deletions.
@@ -2,7 +2,7 @@
"domain": "cloud",
"name": "Home Assistant Cloud",
"documentation": "https://www.home-assistant.io/integrations/cloud",
"requirements": ["hass-nabucasa==0.55.0"],
"requirements": ["hass-nabucasa==0.56.0"],
"dependencies": ["http", "webhook"],
"after_dependencies": ["google_assistant", "alexa"],
"codeowners": ["@home-assistant/cloud"],
@@ -16,10 +16,10 @@ bluetooth-adapters==0.5.1
bluetooth-auto-recovery==0.3.3
certifi>=2021.5.30
ciso8601==2.2.0
cryptography==37.0.4
cryptography==38.0.1
dbus-fast==1.13.0
fnvhash==0.1.0
hass-nabucasa==0.55.0
hass-nabucasa==0.56.0
home-assistant-bluetooth==1.3.0
home-assistant-frontend==20220907.2
httpx==0.23.0
@@ -132,6 +132,3 @@ iso4217!=1.10.20220401

# Pandas 1.4.4 has issues with wheels om armhf + Py3.10
pandas==1.4.3

# pyopenssl 22.1.0 requires pycryptography > 38 and we have 37
pyopenssl==22.0.0
@@ -42,7 +42,7 @@ dependencies = [
"lru-dict==1.1.8",
"PyJWT==2.5.0",
# PyJWT has loose dependency. We want the latest one.
"cryptography==37.0.4",
"cryptography==38.0.1",
"orjson==3.7.11",
"pip>=21.0,<22.3",
"python-slugify==4.0.1",
@@ -16,7 +16,7 @@ ifaddr==0.1.7
jinja2==3.1.2
lru-dict==1.1.8
PyJWT==2.5.0
cryptography==37.0.4
cryptography==38.0.1
orjson==3.7.11
pip>=21.0,<22.3
python-slugify==4.0.1
@@ -829,7 +829,7 @@ habitipy==0.2.0
hangups==0.4.18

# homeassistant.components.cloud
hass-nabucasa==0.55.0
hass-nabucasa==0.56.0

# homeassistant.components.splunk
hass_splunk==0.1.1
@@ -615,7 +615,7 @@ habitipy==0.2.0
hangups==0.4.18

# homeassistant.components.cloud
hass-nabucasa==0.55.0
hass-nabucasa==0.56.0

# homeassistant.components.tasmota
hatasmota==0.6.1
@@ -142,9 +142,6 @@
# Pandas 1.4.4 has issues with wheels om armhf + Py3.10
pandas==1.4.3
# pyopenssl 22.1.0 requires pycryptography > 38 and we have 37
pyopenssl==22.0.0
"""

IGNORE_PRE_COMMIT_HOOK_ID = (

0 comments on commit f41b69e

Please sign in to comment.